Вышел jQuery 3.0

jQuery 3.0

Встречайте jQuery 3.0! Эта версия была в разработке с октября 2014 года. Целью команды разработчиков было создать более легкую и быструю версию jQuery (с обратной совместимостью конечно). Они удалили все старые костыли IE и воспользовались более современным веб-API, там где это имело смысл.

jQuery 3.0 является продолжением ветки 2.x, но с некоторыми изменениями, потребность в которых была давно. Старые 1.12 и 2.2 ветки будут продолжать получать критические патчи, но они больше не будут включать какие-либо новые функции или серьезные изменения. jQuery 3.0 - это будущее jQuery. Если вам нужна поддержка IE6-8, вы можете продолжать использовать последнюю версию 1.12.

Несмотря на номер версии 3.0 ожидается, что переход на новую версию не должен вызвать слишком много проблем, когда речь идет о модернизации существующего кода. Да, есть несколько "глобальных изменений", которые оправдывали мажорную версию релиза, но будем надеяться они не повлияют на большое количество людей.

Для оказания помощи по обновлению, разработчики рекомендуют новое руководство по обновлению до версии 3.0. А плагин jQuery Migrate 3.0 поможет вам определить проблемы со совместимостью в коде.

Вы можете получить файлы из jQuery CDN, или подключить их напрямую:

https://code.jquery.com/jquery-3.0.0.js

https://code.jquery.com/jquery-3.0.0.min.js

Вы также можете получить релиз из npm:

npm install jquery@3.0.0

Кроме того, мы настоятельно рекомендуем использовать jQuery Migrate 3.0, чтобы устранить проблемы, связанные с изменениями в JQuery 3.0. Вы можете получить эти файлы здесь:

https://code.jquery.com/jquery-migrate-3.0.0.js

https://code.jquery.com/jquery-migrate-3.0.0.min.js

npm install jquery-migrate@3.0.0

Дополнительные сведения релизе и всех изменениях вы можете прочитать здесь.

 

Добавить комментарий


Защитный код
Обновить